Quest 2 problems / errors - gloves, shields, plates

me and 2 buddies have been playing on quest since its launch and mostly have been loving it, sadly the more we play the more critical problems we have been running into.

these problems we have been in the past week, tried repeatedly between 3 people… and including server restarts… tried countless alternatives to get them to work and will be listed accordingly.

  1. in character creation, i have put the fingerless gloves “paid” AND the gold hand jewelry on my avatar… and NEITHER show up to me nor friends in the quest versions. i have completly removed and “trashed” the saved doll and started from scratch 4 times now… changed colors… removed and put back on… all with no luck.

  2. between the 3 of us we CANNOT assemble a crafted wood shield. i have both left and right partitions crafted… the folded center crafted… as well as the shield handle. the side partitions will not connect… NOR show guide lines for assembly. the handle DOES show the guide lines and when the handle is placed near… changes to lighter green for connecting… and when released, simply falls to the floor without connecting.
    this has been done with both left and right hands… and several times over a week between 3 people with no success.

  3. metal plates in the crafting station. the water bucket backpack, the tool loop for backpacks, and moulds for weapons, cannot be built past the point of adding metal plates. we have not tried any other recipies for crafting with plates but at this point assume its the same for all. everything builds fine up to the point the plate highlights blue for it to be added… but putting ANY plate… copper, gold, iron, red iron, fails to activate the ghost outline from blue to green… and accept the plate into the craft build.
    we have tried various metals… umongst 3 people daily over a period of a week with no success, including searching for “odd placement points” off build similar to the final anchor point for the bag lamp pole. but to no avail.

as for why i am placing this under feedback and not bug reports… i give you what i was told from the discord.
---- OddMellon - #welcome #sections — 08/03/2021
They should appear like any other cosmetic… go into the Customization house by the carpentry shop in your main server, and make sure the mannequin there is wearing the gloves
[6:07 PM]
If it is, and you go back outside and neither you nor anyone else can see them, file a bug report at feedback.townshiptale.com

For the shield crafting, you must hold the handle and let go of the panel. Same thing when you make a weapon. You hold the handle and let go of the blade. Not sure about the other issues.

riches suguestion for the shield has worked… THAT problem solved. thank you.

plate problem was also fixed… thanks to our “dedicated” blacksmith NOT pounding out the plates when they should have been.

this leaves the gloves problem still,