Unable to drink stew from gourds

Description:
If I fill a gourd with stew (pumpkin stew is what I’ve tried) it usually fills OK after a few tries, but when I try to drink from it, the contents just spill on the ground and I get no nutrition, no fullness and no drinking sound (I do however see the gourd is empty afterwards). I’ve tried holding the gourd close to my face and carefully tipping it as I would do IRL, but also tipping it over my head, like with a teleport potion. None worked. I’ve tried 4-5 times with no success, but if I’m not misremembering, I used to be able to drink from gourds previously.

Reproduction Steps:

  1. Fill an empty gourd with pumpkin stew.
  2. Try to drink it by moving it to your face and tipping it upside down.

Expected result:
Increased nutrition and fullness, as well as a drinking sound.

Actual result:
An empty gourd and no added nutrition or fullness and no drinking sound.

Server:
Private Quest server (original Quest).

Time:
Ca 14.45 CEST.

Dicord Username:
Limewood

I’m not allowed to upload the logs, as I’m considered a ‘new user’, but I have saved them and can send them to you if you DM me on Discord